Lopi Pioneer Pellet stove - need help

mikus29February 25, 2012

My lopi stove blew its fuse and caused the home circuit breaker to open as well. I replaced the fuse and reset the breaker. Plugged the stove back in and the control panel has no power(or anywhere else that I can tell).

I tried a different outlet with verified power, also.

Can anyone help me figure out what to look at next? Could a power surge have fried the control panel before the fuse did its job? Is there some other sacrificial component within the stove I should check? Is there a reset procedure not found in the owners manual?

I've combed the owners manual and can find no reference to a second fuse or other electrical protection features.

It's getting a bit chilly with just cheap electric heater fans going.... brrr...

Thank you for reporting this comment. Undo
mikus29

Problem solved. There is a fuse on the control panel that is not listed in the owners manual. After finding and replacing that fuse and dismantling the feed screw in the hopper, the stove is now operating normally. It must have been an obstruction binding up the the pellet feed screw, causing an electrical overload.

    Bookmark   February 26, 2012 at 12:17AM
Sign Up to comment
More Discussions
Gas Fire Place
I have a direct vent gas fireplace with a standing...
JakeBrey
Semi-detached home shared flue fireplace
Hi this is my first post to this forum so forgive me...
hiddentrails
Do I need a fireplace in Southern California
I am in the middle of renovations in my town home and...
LARemodel
Help me decide on a fireplace unit for new build
We are doing a gas Heatilator unit. Is there much difference...
brodyt
Fireplace Options?
Looking to put a wood burning fireplace in our new...
rmverb
© 2015 Houzz Inc. Houzz® The new way to design your home™