Problems with Philips 27PT543S37A

vihurricaneOctober 18, 2006

I have a Philips 27PT543S37A with chassis number L01-1UAC-7638. As of recently, when I turn the television on, the green power indicator light comes on at the front, but I get no picture or sound. I don't get any sign that the television is even trying to acquire picture or sound for the television. The picture had been collapsing and re-opening on me for a few days, but it would always fix itself. Any one have any clue of this is a simple fix and how I can go about getting it to work again. I would really appreciate the help.

Sign Up to comment
More Discussions
previous post about 50ML8105D
My previous post about my Magnavox/Phillips 50"...
tribefan53
50" dlp tv
Here is a picture of the whole part...
tribefan53
home stero using XM radio
i am building our retirement home and have installed...
coetexas
transfer hi8 tapes from sony ccd-trv98 to mac ??
Hi ~ What is the best and fastest way to transfer Hi8...
kathybeachgirl
Philips/Magnavox Tv Problems ?
To get assistance on Philips/Magnavox TV: Post the...
pee_wee
Sponsored Products
Coaster Bunk Bed 460441
Beyond Stores
Cosby Sofa - Cordova Picante Orange
Joybird Furniture
Happy Picasso Red Loveseat
bryght.com
Ambiance Hammered Iron LED Big Metro Wall Sconce
$650.00 | Bellacor
Element E3S-A 3" Square 19W LED Adjustable Housing
| LBC Lighting
Constant Coral Giclee Glow 10 1/4" Wide Pendant Light
$99.99 | Lamps Plus
ELK Lighting 66201-2 Semi Flush - 13W in. - Matte Black - 66201-2
$78.00 | Hayneedle
Red Balls Ava 6-Light Nickel Pendant Chandelier
Lamps Plus
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™