phillips 27pt543s37a tv problem

ibrokeitAugust 12, 2008

I have a 27" Phillips TV model No. 27PT543S37A chassis L01.1U I have had it for about 2years now, and until last year it was working fine. It started as having trouble turning on it would start then shut off several times really fast, then completely shut off it would take about 3 or 4 times of turning the tv on before it would work. When it come on the image would shake, eventually it turned into taking about 3-7minutes to get the tv on and another 3-4 minutes for the image to slowly creep back from the middle of screen after that it would work fine. Now the tv will not turn on at all and when plugged in it makes a chirping sound.

has anyone fixed this problem and if you did could i ask what you replaced. i have heard 50 different answers and i dont feel like replacing every chip in the tv.

Sign Up to comment
More Discussions
modem switch, ethernets, and extension cables
Hi, I'm hoping someone can steer me in the right direction....
jally
Sounds like a fan going bad
I have a Magnavox 50ML8105D/17 (DLP-TV)..there is a...
tribefan53
why do I have to "install"apps on my tablet?
So why do I have to install apps on my tablet that...
clairebuoyant1
Best and thinnest flat screen wall mountable tv less than 20" high?
I am so out of my depth here. I would greatly appreciate...
bellsmom
plug-in 15w bulb caused sticky mess (wax melt)
Stupid me, I bought a plug-in wax melter / tart-warmer...
jally
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™