My TV is possessed!

alisandeJune 3, 2007

I bought a 24" Sony flat-screen TV for my bedroom in 2002. It has had very light use as a television for the past four or five months (I acquired TV reception only recently, via an outdoor antenna), and before that had very light, only occasional use with DVDs.

The other day I tried to turn it on with the remote as usual, but nothing happened. A red light came on at the TV button on the remote every time I did something, but that's all. So I turned on the TV at the set. When I wasn't able to change the channel using the remote, I opened the front panel on the set and tried using those buttons. Nothing happened.

I walked away from the set and all of a sudden the volume shot up to the maximum. I ran back and turned it off. A few minutes later I turned it back on and tried reducing the volume using one of the buttons under the front panel. It worked--as long as I kept my finger on the button. But when I removed it, the volume shot back up to the top again.

I unplugged the set for a day while we had some thunderstorms. I just plugged it back in, hoping to find it back to normal, but no such luck. It's still possessed.

Do these symptoms sound familiar to anyone? Does it pay to get a TV like that repaired these days, or should I consider it a lost cause?

Thanks for your help!

Susan

Thank you for reporting this comment. Undo
jdbillp

Sounds like a button is stuck in on the remote.

    Bookmark   June 3, 2007 at 9:50PM
Thank you for reporting this comment. Undo
alisande

I just checked, and it doesn't appear to be stuck. Then I checked the batteries, and discovered they were the original Sonys, now five years old. So I changed them, but that didn't help. The red light still goes on when I operate the remote, but it's off when I don't push a button. So that would indicate that the button isn't stuck, yes?

Thanks for the suggestion.

    Bookmark   June 3, 2007 at 10:39PM
Thank you for reporting this comment. Undo
jdbillp

Yes that should indicate a button isn't stuck.

But I am stuck for any other answers. Sorry.

    Bookmark   June 6, 2007 at 11:06PM
Thank you for reporting this comment. Undo
daft_punk

Sounds like the "volume up" button the TV itself is stuck. This may cause the TV to ignore the remote.

Peace.

Marco

    Bookmark   June 13, 2007 at 5:06PM
Thank you for reporting this comment. Undo
tobr24u

Probably cost you more to repair it than it is worth...ear plugs might be an answer if others don't mind the volume lol!

    Bookmark   June 14, 2007 at 9:51AM
Sign Up to comment
More Discussions
Sounds like a fan going bad
I have a Magnavox 50ML8105D/17 (DLP-TV)..there is a...
tribefan53
plug-in tart warmers - parchment-paper safe?
Hi, re: plug-in wax-tart warmers: Is it safe to cover...
jally
Sound Goes Off Occasionally on TV
I have a Sharp ACQUOS TV. A few days ago, I started...
WalnutCreek Zone 7b/8a
50" dlp tv
Here is a picture of the whole part...
tribefan53
previous post about 50ML8105D
My previous post about my Magnavox/Phillips 50"...
tribefan53
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™