PE Design 2 and XP

hoerlelNovember 7, 2005

Is it compatible? I have read some conflicting threads on using Design 2 if you have XP. I was lucky enough to purchase a Brother PC8500 and the buyer included the PE Design 2 with it. I realize that there has been severl upgrades to Design 6, and I am new to embroidery so I was wondering if there would be some kind of conflict.

Thank you for reporting this comment. Undo
msmeow

Hi, Lucy (we're both here from the Quilting forum!) - I have the same machine you do, and PE Design 2.5. I also have Windows XP and I have never had any trouble. I occasionally encounter an error in reading a file, but it's usually because it was created in a higher version of PED and the older version can't read it.

I think up to PE Design 4.something the program used the same reader/writer box and card that you have, but the newer versions have a different box and card, so if you want to upgrade, beware of buying those $25 versions on EBay - I've heard they are pirated, and they don't come with the box and card. I'd get the upgrade through a Brother dealer who will supply the new box and card. It's going to cost you a few hundred bucks if you decide to do it!

Donna

    Bookmark   November 9, 2005 at 3:49PM
Sign Up to comment
More Discussions
Brother PC8500 Memory Card
I recently acquired a Brother PC8500. As this is my...
rschum6718
Bobbin Thread Rising into Embroideries
I have a new (since February) Huqsvarna Rose sewing/embroidery...
pchoench
Making letters
What is the best way to make my letters and words even?...
tim45z10
Help with embroidery
I just recieved the Brothers SE400 sewing and embroidery...
JordonWalker0722
Machine embroidery
I have a white 3300 embroidery machine I cannot figure...
Papillons
© 2015 Houzz Inc. Houzz® The new way to design your home™