PE-Design & 150 Help!

tnkrbelJuly 16, 2007

I have looked back several pages, but I don't see anything that can help, so I signed up so I could ask some questions! I have the PE-150 and the PE-Design (v.2.0).

First Question: Recently, when I have been using my PE-150 the thread has been catching at the bottom, making a huge knot and jamming the design up. Any ideas or suggestions?

Second Question: I have a design that I am trying to save on my card, but when I tell it to save, after a few seconds it says "Writing to the original card failed. No card writer module is connected" but it is. Well, I tried breaking the design down to seperating the text from the image, and it will save the text to the card, but I get the same error when I try to save just the image. Could it be that the image is too big? I have saved larger looking images to the card before...I really need to get this image on the card. Any help would be greatly appreciated!

Thank you for reporting this comment. Undo
Laura_IA

This could be many things and it's been ages since I've used PE Design, but I'll try :)

On the thread nesting, unthread and rethread your machine, usually when there is a problem with thread nesting below the design, the problem is somewhere in the thread path above the design. It could be that the thread is not pulled into the tension disk fully, or it is coming out of the pull-up lever. Also, once when I had this problem I discovered that I had a tiny burr in the throat plate right on the edge of the whole where the needle goes through. A little bit of very fine sandpaper very carefully rubbed on it took care of that. Basically, check your complete upper thread path to make sure you're threaded correctly and that there are no rough spots where the thread could be catching.

On the design issue, have you ever been able to use this design the way it is? I suspect that you are correct in that the design is too big if the text was fine by itself. You have to make sure that all the edges of the design field are completely within the hoop edge on your screen. I believe there are little black squares that indicate the 'frame' of the design. I used to think that those could be ON the line of the frame, but they have to be completely INSIDE it.

If you're still having problems, post back and we can do some more troubleshooting!

    Bookmark   July 16, 2007 at 10:26PM
Thank you for reporting this comment. Undo
tnkrbel

Thank you so much for your reply!

Yep...I had a burr in the plate. I sanded it down. I haven't tried it yet, but I'm sure that was what the problem was.

Also, even though I had tried resizing the image with PE-Design's Layout & Editing, it didn't work. But, I downloaded a free trial of BuzzSize, and that did the trick! Once I resized it with that, it copied to the card with no problems.

Thanks again!

    Bookmark   July 18, 2007 at 8:17PM
Thank you for reporting this comment. Undo
tnkrbel

OK...so filing down the burr on my plate did work (thanks!), but now I guess it is my PE-Design box that is going bad. No matter what size the file is now, it won't save, and I keep getting diferent error messages, but usually ones that say it can't access the com port or that the device isn't connected (which it is). It used to be hit and miss if it would save to the card, and now it just won't save anymore.

So, I have come to the conclusion that I'm going to have to get a new device to save my files to the card.

So, my new question is, can I get the PED-Basic (which is sold at WalMart for $99 but I have seen it on ebay for around $30) and will it still work with my older (v. 2.0) PE-Design software? Or is there another device/prgram that you would recommend that is not that expensive (I'm thinking $200 or less)?

Also, I have tried doing the upgrade to v. 2.5, but I get errors with that as well (could it be because my device is going bad?)...any suggestions?

    Bookmark   August 25, 2007 at 3:15PM
Thank you for reporting this comment. Undo
pegpeg

My PED-Basic came from WalMart and I have not had any problems. But, I do know that I can not download any designs that will not fit my Brother PE-150, which is no larger than a 4x4 size. At least I've never thought I could use a larger size on this type machine. I'd like to know how~~if possible? Also, I just posted a question as to my machine not picking up the bobbin thread. According to one of your answers, maybe I have a burr in my throat plate hole. Going to check right now. What do I look for?

    Bookmark   September 24, 2007 at 2:35PM
Thank you for reporting this comment. Undo
msmeow

I have PE Design and it's R/W box, too, but I don't know anything about PED Basic. I think I'd go to Brother's website and find a dealer, give them a call, and ask your questions. Tnkrbel, I have a similar problem with my Amazing Box. I think maybe my new-ish computer is too smart for my older box. I know Brother changed the box when they got to PE Design 4 or so.

Donna

    Bookmark   September 25, 2007 at 3:36PM
Thank you for reporting this comment. Undo
tnkrbel

I ended up getting the PED-Basic. WalMart had them on clearance for $68 so I snagged it. Now I am having no problems transfering my designs. My only "issue" is the fact that I have to hook up my old box to use my PE-Design program, then un-hook that and hook up my new box to write it to the card. It's a pain, but I'm dealing with it! Any ideas where I can get a patch for v2.5 (I was also finally able to load the upgrade) so I don't have to do this?

New issue: when I am sewing any font that is arched, the bobbin thread now comes through to the top. It didn't do this before. Grrr!

As for what to look for with the burr, I'm assuming you know what plate we are talking about? Just rub your finger over the plate. If you feel anything rough, that would be a burr. HTH!

    Bookmark   November 7, 2007 at 11:37PM
Thank you for reporting this comment. Undo
crazy-crafter

I am having issues with PE-Design 2.5 also. I have PED-Basic with the R/W box that connects to a USB port. I also have PE-Design 2.0 upgraded to ver 2.5 (no R/W box for it) I recently installed them on my Dell running WindowsXP (previously on computer running Windows98). I can not get Design center to run at all. I get error message "No Card writer module connected..." I know it is connected and working as I can use it in PED-Basic. I am assuming PE-Design is looking for it to be connected through a com port? I have tried to changed the available ports through PE-Design's Utility but no luck. Anyone know how to get PE-Design to recognize the R/W box?

    Bookmark   November 19, 2007 at 6:48PM
Sign Up to comment
More Discussions
Help!! Anyone have a Brother SE-270D embroidery unit?!
Help! I made a huge mistake. I knew nothing about sewing...
Caitmon
Husqvarna-Viking Designer 1 Software
Hi all, I have recently decided to try out the embroidery...
MaryPrim
Help with embroidery
I just recieved the Brothers SE400 sewing and embroidery...
JordonWalker0722
thread breakage
Help please. I have a Futura CE200. All was well. Have...
crittersareme
list of free design sites
Does anyone have a list of site that have free designs?...
crittersareme
Sponsored Products
Van Teal Slick Chic Cafe Noir Table Lamp
Euro Style Lighting
Design House 517979 Barcelona 3-Light Downlight Chandelier - Satin Nickel Finish
$168.99 | Hayneedle
Worlds Away - Neal Coffee Table with White Marble Top - NEAL GW
Great Furniture Deal
Safavieh Handmade Moroccan Cambridge Navy/ Ivory Wool Rug (10' Square)
Overstock.com
Gray Sunburst Jacquard Tablecloth
$14.99 | zulily
Americh Mezzaluna 6032 Left Handed Tub (60" x 32" x 20")
Modern Bathroom
BLux | Ovo ADA Wall Light
$704.80 | YLighting
BiOrb Life 16-gallon Aquarium
$525.00 | FRONTGATE
© 2015 Houzz Inc. Houzz® The new way to design your home™