Philips/Magnavox 26mf605w/17

strawboss59March 11, 2006

Chassis # is: BZ000525370693 (serial #?)

This is a 26 inch hd lcd tv, 4 months old with the following problem that is intermittent 6-7 times. When I turn the set on I get audio but no video as if the backlight isn't turning on, but.... turning it off then on again sets things right....so far!

Anyone have the same/similar problem?

Things like this usually get worse....

Thank you for reporting this comment. Undo
strawboss59

Well..... it just now blew up, off to the repair shop!
The set let loose with 2 seconds of bllaaatt then nothing but a smell of ozone hanging in the air & a black screen.
I may post a repair cost if I decide to go that route, but one thing for sure I'll never buy from this manufacturer again...

    Bookmark   January 28, 2007 at 12:07PM
Thank you for reporting this comment. Undo
strawboss59

It was the power supply $376.00 out the door.
Hoped that the intermittent problem with the backlight would go away, but no luck.....it will go for weeks before acting up.

    Bookmark   April 17, 2007 at 2:28PM
Sign Up to comment
More Discussions
arc breakers tripping
We have arc fault breakers and one of them keeps tripping,...
newhomeseattle
vizio xvt473sv dead
I have a 4 year old VIZIO XVT473SV that now has NO...
thew60
Sounds like a fan going bad
I have a Magnavox 50ML8105D/17 (DLP-TV)..there is a...
tribefan53
hdmi connection
i have a hd tv but standard cable. no hd premium service....
stoveguyy
Throw them away ?
I have a DVD player, a cassette player , a tuner ,...
salbwil
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™