Magnavox 30MW5405 trouble, Shuts off

handyman1176February 7, 2010

I have a 4 year old Magnavox 30MW5404/17 Chassis L05U AA that suddenly turned itself off with no warning or prior problems. Turning it on gives no picture and only a few seconds of sound before shutting back off. The power light after "shut off" repeatedly blinks 3 short and 1 long. The usual click heard when turning on or off is quieter than usual. Took back off. When turned on, there is a faint buzz near the back of the CRT tube or from the horizontal PCB mounted there. Coming from the balance coil mounted on that board??

I saw many on this forum guided by Pee Wee who were able to find a bad resistor or cap and fix units with the same problem but on units older than mine. I can not find similarly described resistors on my unit. I did random testing of resistors and could not find any open ones. Can't find any bloated caps or signs of damage. Does anyone (Pee Wee?) have any ideas? I hate to toss a great TV bc/ of a potentially minor failure.

Thank You

Sign Up to comment
More Discussions
cheap tv
got a nice working fully functional 32" lcd yesterday...
stoveguyy
Lost sound on my computer.
Once again I need your help. I have been persuaded...
ronalawn82
aspect ratio
We have 2009 insignia LCD. Am using Comcast mini hd...
stoveguyy
Sound Goes Off Occasionally on TV
I have a Sharp ACQUOS TV. A few days ago, I started...
WalnutCreek Zone 7b/8a
Headphone jack
Dug up a sub-mini plug for my home phone earphone jack....
stoveguyy
© 2015 Houzz Inc. Houzz® The new way to design your home™