magnavox 30mf200v/17 lcd tv no picture

doodmanJanuary 20, 2008

Hi there! I tried the search function first, but it wasn't working for me. Anyway, my neighbors gave me an LCD TV (Magnavox 30MF200V/17) because it has no picture. They say the audio works fine though. It turns on fine, but I get no picture. I haven't hooked up a source to it to verify audio, but I'm sure if they say the audio is fine, it is.

Anyone have experience with this model/problem? I'm thinking maybe the backlight inverter could be bad. But without a schematic, I don't know what to check. I've got an o-scope and DVM so I can troubleshoot. Just need some test points with what I'm supposed to see :) Thanks in advance!

Thank you for reporting this comment. Undo
regus_patoff

did you try it with various inputs (if equipped)

SVideo, component video, composite video, ect...

    Bookmark   January 20, 2008 at 5:21PM
Thank you for reporting this comment. Undo
    Bookmark   January 20, 2008 at 5:41PM
Thank you for reporting this comment. Undo
doodman

I somewhat found the problem. I turned out the lights and then tured the TV on. Right after powering up, the backlight flahses for about 1/10 of a second then goes out. Then about 4 seconds later, it comes back on, only for about 1/2 of a second. I was poking around on the backlight inverter board at the backlight controller IC. I can't recall the part number, but it's a 20 pin IC. I think it was pin 13 (listed as TC on the datasheet), if I held my scope probe on that pin, the backlight would come on and stay on (only if I held my probe on there while powering it up and keeping it on that pin). Otherwise, if I took my probe off of that pin it would go out instantly. The waveform was that of a sawtooth. I didn't measure frequency or amplitude. After touching up the solder on those pins and components nearby, it seems to be ok now, backlight stays on (without me having to hold the probe on that pin). Yay :)

    Bookmark   January 21, 2008 at 11:12AM
Thank you for reporting this comment. Undo
doodman

Actually, it's pin 18 of the controller IC. It worked great for about a week. Turned it on this afternoon and it's doing the same thing. Gonna try to get the schematic for this TV as the picture is nice. Was using it as a PC monitor for a few days. Wish me luck!

    Bookmark   January 28, 2008 at 5:20PM
Thank you for reporting this comment. Undo
distressed_techie

Doodman,

Recently I acquired *SOUND OF WIFE CLEARING THROAT* Ummm...
trash picked the same tv as you got from your neighbor and I am having the EXACT same problem as you are/did. If you could I would like a copy of the schematics/a reiteration of what you did to get it to work.

Thank you,
Distressed Techie

    Bookmark   October 3, 2008 at 11:08PM
Sign Up to comment
More Discussions
Where to buy cassettes for music
We still play cassettes in two of our old cars. I need...
loralee
Sounds like a fan going bad
I have a Magnavox 50ML8105D/17 (DLP-TV)..there is a...
tribefan53
50" dlp tv
Here is a picture of the whole part...
tribefan53
I need "Pairing Code" information for my TV.
What is the pairing code for my Magnavox TV Model #...
Tammy Lanier
arc breakers tripping
We have arc fault breakers and one of them keeps tripping,...
newhomeseattle
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™