Viking Hood installation

paul46December 9, 2012

Hi folks, this is my first post on the appliance forum.
I just installed a Viking Hood model VCWH3648SS a 36" wall mounted unit. I Installed a DIL1200 in-line fan. I followed all the wiring instructions. The lights work as expected with the dimmer. The fan turns on, but it seems to be at the lowest speed. the Low/High speed control has no effect. I am at my wits end, can anyone shed any light? Has anyone used the JustAnswer site for advice? they want $30 to attempt to answer my question.
Help!
thanks,
Paul

Thank you for reporting this comment. Undo
jgopp

This was one of my many problems when installing my viking hood. I had to get a replacement controller from viking to solve this issue.

    Bookmark   December 9, 2012 at 6:05PM
Thank you for reporting this comment. Undo
paul46

Thanks jgoop, I have replaced the controller and now it works as expected.

    Bookmark   December 12, 2012 at 8:55AM
Sign Up to comment
More Discussions
New KitchenAid launch in April 2015
Hi, everyone. Sorry if this has already been discussed....
kiwigem
Help Me Choose A Wall Oven
I have a Gaggenau 24" inch convection oven over...
heron3
steam damage to cabinets from steam oven or warming drawer?
When we had a kitchenaid dishwasher, the hot moist...
houztongirl
Need Advice on Best Gas Range/Cooktop for Short Person
I will be getting either a new gas cooktop or a dual-fuel...
yaupon
Single Electric Wall Oven: WHY is it so hard to find a good one?
Hi everyone! We are finally WELL underway with our...
lovelylinguist
© 2015 Houzz Inc. Houzz® The new way to design your home™