Viking Hood installation

paul46December 9, 2012

Hi folks, this is my first post on the appliance forum.
I just installed a Viking Hood model VCWH3648SS a 36" wall mounted unit. I Installed a DIL1200 in-line fan. I followed all the wiring instructions. The lights work as expected with the dimmer. The fan turns on, but it seems to be at the lowest speed. the Low/High speed control has no effect. I am at my wits end, can anyone shed any light? Has anyone used the JustAnswer site for advice? they want $30 to attempt to answer my question.
Help!
thanks,
Paul

Thank you for reporting this comment. Undo
jgopp

This was one of my many problems when installing my viking hood. I had to get a replacement controller from viking to solve this issue.

    Bookmark   December 9, 2012 at 6:05PM
Thank you for reporting this comment. Undo
paul46

Thanks jgoop, I have replaced the controller and now it works as expected.

    Bookmark   December 12, 2012 at 8:55AM
Sign Up to comment
More Discussions
48" Wolf, Thermador or Bluestar...or something else?
Looking into purchasing a 48" range. Wolf: Classic....
wren21
Daily Luxury Convenience (Combi Steam) vs. Tried & True Dbl Oven
I asked questions about the steam oven last month....
lawjedi
Island hood location/height
I've got a cooktop that's 20" X 37" that...
dickross
Why are my frozen bananas melting?
Not sure the right forum for this, but I freeze bananas...
weedyacres
New KitchenAid launch in April 2015
Hi, everyone. Sorry if this has already been discussed....
kiwigem
© 2015 Houzz Inc. Houzz® The new way to design your home™