KA dishwasher won't start, control lock blinks 3X

sandyinvaOctober 14, 2012

I have a Kitchen aid dishwasher, KUDS30IXBT which I bought in Feb 2011. The panel is not lit, and when I try to start it, the Control Lock light blinks 3 times. I have tried pressing the energy saver dry cycle for 15 seconds, (and every other button, it seems) to see if I can release the lock. I also turned off the power to see if it would reset. Anyone suggestions before I call a repair person to look at the control panel?

Thanks in advance,

Sandy

Thank you for reporting this comment. Undo
SparklingWater

I have a Kitchen Aid dishwasher. Is it possible the lock got activated accidentally? Locking is usually undone by pressing the 'air dry' or 'heated dry' button in for about 5 seconds. Try that and see if your lock light goes out. It may depend on your model as mine is older now. Good luck.

    Bookmark   October 14, 2012 at 5:46PM
Thank you for reporting this comment. Undo
sandyinva

Nope, I just tried it, but thanks anyways. It's only me in this house, so things usually don't get hit by accident. I also checked to make sure that the rack goes all the way back and that there are no obstructions.

    Bookmark   October 14, 2012 at 5:52PM
Thank you for reporting this comment. Undo
dadoes

Kill the power for a while -- 10 mins or so -- by unplugging the unit or flipping the breaker. Restore power, check if it works.

There are nine engineering revisions on this unit (a number 0 through 8 should be the last digit of the model number). I picked one at random for the online manual. It indicates a separate Control Lock key.

If power cycling doesn't work, and the Control Lock key doesn't work, then you may have a bad control panel. They do go wonky fairly frequently but usually not so soon.

    Bookmark   October 14, 2012 at 6:30PM
Thank you for reporting this comment. Undo
sandyinva

Thanks, dadoes, I will try it. I had turned it off earlier, maybe not long enough. Can I assume that if that doesn't work, I need to call someone in?

BTW, I purchased my washing machine and dryer based on your recommendations for Fischer and Paykal, 10 years ago, have never needed to call for service.

    Bookmark   October 14, 2012 at 6:36PM
Thank you for reporting this comment. Undo
dadoes

SandyInVA,

Assuming you haven't yet done so, at 10 years, I strongly suggest you have a look-see at your washer's pump for evidence of leaking (rusting, mineral deposits on it). That's one of the few weak spots on F&P. A pump wet from leaking can short-out and kill the motherboard. Doesn't have to be a large leak to puddle on the floor, just a slight dribble that gets and keeps the pump wet will do it. Much better to catch and replace a bad pump before it destroys the board. :-)

    Bookmark   October 14, 2012 at 7:31PM
Thank you for reporting this comment. Undo
sandyinva

Problem resolved. I started touching various controls, and I think, I am not sure, I touched the control lock for an extended few seconds, and the lights returned, and all seems to be working again.

Many thanks for the input, it is so good to know that you all are out there when these things happen.:>)

    Bookmark   October 14, 2012 at 8:24PM
Thank you for reporting this comment. Undo
dadoes

Control Lock must be pressed/held 3 to 4 seconds to enable & disable.

    Bookmark   October 14, 2012 at 8:46PM
Thank you for reporting this comment. Undo
Cavimum

Same thing happened to my sister last week, same model KA DW. She held the Control Lock a few seconds, and all was good.

    Bookmark   October 15, 2012 at 9:41AM
Thank you for reporting this comment. Undo
sandyinva

Wow! almost to the day, it happened again, one year later! Played around touching various controls, touching the control lock for an extended time did not fix it immediately. but something at some point did.

    Bookmark   November 12, 2013 at 6:14PM
Thank you for reporting this comment. Undo
loreenmstay

Thank you!!! Just happened to me, I just restarted the breakers and held the control lock for a wee bit longer then 3 sec...ITS WORKING NOW :)

    Bookmark   March 18, 2015 at 7:09AM
Sign Up to comment
More Discussions
Can a Whirpool wrs342fiab00 Refrigerator use water filter bypass ?
I have an undersink filter connected to this fridge,...
edge
essentials you can't live without in your front load washing machine?
I am trying to purchase a new washing machine for our...
abick2
Finish Detergent
Has anyone tried the new Finish Quantum Max 12X pacs?...
sparky823
Bluestar platinum vs Capital Culinarian
We are deciding on kitchen appliances for our upgrade...
malba2366
Wolf gas/induction modules
We must make a commitment to appliances next week for...
judydenver
Sponsored Products
Sausalito 22" High 3-Light Deep Bronze Pendant Light
Lamps Plus
Dark Cappuccino 3-piece Occasional Table Set
Overstock.com
Varaluz | Fascination 3 Light Bath Sconce
$419.00 | YLighting
Rizzy Home Ivory and Raspberry Flowers Decorative Throw Pillow - T04862
$40.00 | Hayneedle
Corsaire Pendant
Lightology
Azure Vase
$24.99 | zulily
© 2015 Houzz Inc. Houzz® The new way to design your home™