Kenmore Elite induction cooktop shutting off when boiling water

mtrotOctober 27, 2013

This cook top works fine when cooking with small pots on the smaller burners. But when we try to boil water in a large pot for spaghetti, the unit will work for a minute or two, then start beeping and shut off. The indicators will also flash. If we wait 5 minutes or so, the unit will work again, unless you try to boil the water again.

My suspicion is that the cooling fan(s) is not working properly and a sensor is heating up and shutting it down. I can hear a fan running softly, but I think it used to crank up to a lot higher speed. Has anybody had any experience with this behavior, and what was the outcome? Also, if it does turn out to be a fan, is that something that I could replace? I installed the cook top originally, and have decent mechanical abilities.

Thank you for reporting this comment. Undo
kaseki

Rebooting sometimes helps with strange computer problems. Find the circuit breaker that controls the power to the cooktop, and shut it off for a minute. Then retest. This costs little and just might avoid a service call.

kas

    Bookmark   October 27, 2013 at 7:48PM
Thank you for reporting this comment. Undo
mtrot

Thanks, I have already tried that several times. Actually, I shut off the breaker just a few minutes ago, and when I clicked it back on, the cook top started beeping like crazy and all the indicator lights flashing numbers and the letter "F", which I assume means "fault".

    Bookmark   October 27, 2013 at 7:52PM
Thank you for reporting this comment. Undo
jakvis

Is the cabinet under the cooktop getting warm?
Induction units need to have the warm air excape from the cabinet or the fan just sucks in the hot air it just vented. When this happens the sensors will shut down the cooktop.
To test, you can open the cabinet doors or drawer under the cooktop and try boiling water again.

    Bookmark   October 28, 2013 at 4:46AM
Thank you for reporting this comment. Undo
mtrot

Thanks, but we've had this unit for 5 years, and it worked fine until a couple weeks ago. Also, it now doesn't work at all.

    Bookmark   October 28, 2013 at 8:22AM
Sign Up to comment
More Discussions
De Dietrich induction cooktop
Is anyone around that has any data about De Deitrich...
chinchette
motor for bluestar hood
I recently purchased a floor model bluestar range and...
shelly_ok
Wolf porcelain chipping on new ovens
Argggggg!!!! New wolf E series ovens, purchased and...
jackson2348
good experience with AJ Madison
Got a really good deal on $5k worth of Bosch appliances...
logastellus
Who makes Counter Depth fridge less than 36" wide
Hi, who makes a counter depth fridge that is only say...
Brad Goodyear
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™