Wolf AG burner igniters

hawksterAugust 24, 2012

The piezo burner igniters on my six-year-old Wolf AG have become notoriously unreliable. The igniter post and simmer ring become routinely oxidized, allowing little or no spark to form. I take an abrasive pad to them regularly (like two or three times a week), but this is a total PITA. Has anyone come up with a fix for this? I've thought of completely stripping the anodized coating off the burner rings, but this seems extreme, and perhaps pointless if the brass reoxidizes anyway.

Thank you for reporting this comment. Undo
SparklingWater

hawkster, any improvement on this Wolf AG ignitor sparking problem for you? Did you contact Wolf about this problem?

Your post is not so old. I'm wondering if any other Wolf AG users have similar igniter problems? thnx.

    Bookmark   September 10, 2012 at 6:32PM
Sign Up to comment
More Discussions
motor for bluestar hood
I recently purchased a floor model bluestar range and...
shelly_ok
How do you get deals on high-end appliances?
I'm pretty certain that I know what I want for my appliances....
carecooks
Shark Hard Surface Steam CleanerSE3306C steam not coming out of nozzle
Hi, Our Shark Hard Surface Steam Cleaner is heating...
danadevy
Install Question for Subzero Undercounter UC24 BG/S Beverage Center
We're looking to install a Subzero UC24 BG/S Undercounter...
pbx2
2 Weeks With my New ASKO Dishwasher--a review
Since very few people here have ASKO dishwashers or...
needinfo1
© 2015 Houzz Inc. Houzz® The new way to design your home™