Can't open .exe files in Vista

Pooh BearMay 17, 2011

Vista Home Premium

I was working on cleaning off a trojan (vista defender 2011) and I think I got some of it cleaned up, but when I went to open Internet Explorer, it asked me what program I want to use to open it with. Since it was just a shortcut, I chose IE. Still no go. I used another computer to download SuperAntiSpyware and MBAM. I placed them on a flash drive and copied them to the desktop of the Vista computer. Same problem when I click on them to install them. It asked me what program do I want to use to open this file.

I tried booting to last known good configuration. No help.

I am completely at a loss at this point.

Thanks in advance for any help you can give.

Pooh Bear

Thank you for reporting this comment. Undo
zep516

You may have a borken EXE file association problem, probably from the Malware. The computer should be taken to a malware removal forum for further analysis. Broken EXE associations will show up in more thorough scans used by those forums. In the mean time here's a link for fixing the EXE association issue in Vista. You may need to download it onto a flash drive, just click the EXE in the box provided on the web page the link below takes you to...

Good luck.

Here is a link that might be useful: File-association-fixes-for-Windows

    Bookmark   May 17, 2011 at 5:16PM
Thank you for reporting this comment. Undo
ravencajun Zone 8b TX

Yes that fake vista rogue is hitting seen it a few times now, definitely suggest going to LzD and starting a thread there of your own they will help you run those specialized scans to get the rest of that thing off there.
Analysis and Malware Removal

    Bookmark   May 17, 2011 at 6:58PM
Thank you for reporting this comment. Undo
Pooh Bear

That took care of the exe problem and now programs open just fine. I installed SAS and MBAM and both scans seem to have taken care of the problem. Now I have another problem.

When I turn on the computer I get this error message at startup:

I also get that message if I try to open Windows Defender from Control Panel.
Any ideas on how to resolve this.

Thanks so much for your help.

Pooh Bear

    Bookmark   May 17, 2011 at 9:14PM
Thank you for reporting this comment. Undo
kudzu9

Try this...

Here is a link that might be useful: How to fix

    Bookmark   May 17, 2011 at 10:22PM
Thank you for reporting this comment. Undo
Pooh Bear

Web of Trust flagged that site before it could load.

I disabled Defender in msconfig and now I don't get the error.
Probably not a permanent solution but works for now.

Pooh Bear

    Bookmark   May 18, 2011 at 12:04AM
Sign Up to comment
More Discussions
What's with this new Houzz thing?
Been away a couple days, and came back to this, what...
shaddy101
About those Garden Web Styles themes and skins for Firefox
I see they are authored by GW members. Thank you everyone....
Chemocurl zn5b/6a Indiana
need help again regarding free office program
I asked for help in this area recently and never was...
Lea Grabb
Hmmmm...can't "scroll" thru sites anymore on laptop?!?!!?
WTH?!?! My Del Inspiron laptop has decided that it...
Faron79
Need help turning old computer into HTPC
I have an old computer. c2001. Motherboard is a D865GBF,...
Pooh Bear
© 2015 Houzz Inc. Houzz® The new way to design your home™