induction cooktop stuck in 'control lock'

louisa_smith03July 10, 2008

My GE Profile 30" cooktop was put into "control lock" last week. This means that the burners don't turn on, but you know the unit is stil getting power because there is a little red light on next to the "control lock" label. the way it's supposed to work is you touch that label for a few seconds and it becomes unlocked and ready to use. Doesn't work. and even after cutting off power to the cooktop by flipping the breaker for a few minutes, then flipping back on had no effect. GE will have a technician come out next wedsday, but meanwhile, does any have any ideas about what is going on? Anyone else have this problem? shot in the dark, but it may work out!

meanwhile, I'm thinking the extended warranty is not such a bad idea after all . . .

Thanks!

Thank you for reporting this comment. Undo
remodelfla

Is there a way you can try to unplug it? I don't know why but with a variety of electronics I've found that unplugging, waiting a 5 minutes and plugging back in sometimes work. Might have something to do with it going back to some kind of default. There's my very untechnical advice!

    Bookmark   July 10, 2008 at 5:08PM
Thank you for reporting this comment. Undo
louisa_smith03

thanks for your response. I can't figure out how to unplug it, but I thought flipping off the circuit breaker would maybe do the same thing as unplugging?

Call 1-800- GE- CARES. i kid you not. Sure, they build crappy appliances, but, hey they CARE.

    Bookmark   July 11, 2008 at 1:42PM
Thank you for reporting this comment. Undo
pbrahm1_wi_rr_com

Hi Louisa...just installed the same GE cooktop and am having the same problem. The control lock light is on and doesn't respond to finger touches. Have flipped the circuit breaker as well. Nothing. I'd rather not wait for service for another week. I've already been without a stove for a week when the granite counter tops were suppose to be installed but arrived broken! Atleast I have a sink now!! Please don't tell me I need another cooktop. What was your resolution?!

    Bookmark   August 16, 2008 at 8:57AM
Thank you for reporting this comment. Undo
llaatt22

Not much on the web in the way of fixes. One suggestion is to shut off the circuit breaker for a minimum of five hours or overnight. This sounds logical because some have reported the problem cleared after an extended power outage. Other suggestions are to keep hot or hot and wet objects like pot lids, pans etc away from the area next to the control panel and the area immediately above it.

    Bookmark   August 16, 2008 at 12:09PM
Thank you for reporting this comment. Undo
pbrahm1

Bummer...no such luck. We had the circuit breaker off overnight. Was really hoping your suggestion would work!! Thanks for trying!

    Bookmark   August 16, 2008 at 8:39PM
Thank you for reporting this comment. Undo
klaa2

What electric rated breaker and line do you have supplying the cooktop? You said the unit was 'put into' control lock. What do you mean by this? Did it do it itself or did you touch the lock control long enough to activate it? Has this cooktop worked before this happened?

Could it be that the unit is in this mode as a safety feature? If it is not powered correctly, you will have all sorts of problems.

    Bookmark   August 17, 2008 at 10:40AM
Thank you for reporting this comment. Undo
try_hard

I don't have any suggestions for you but will say that I have had the 36" GE Profile induction cooktop since April. I had to have the glass top replaced (under warranty) due to a big scratch and when the technician was here I told him that my Control Lock button did not seem to work. When he lifted off the top he adjusted the touch sensor for the Control Lock so that it was closer to the glass and therefore, sensitive to my touch.
Good luck,
Try_hard

    Bookmark   August 17, 2008 at 10:19PM
Thank you for reporting this comment. Undo
lightlystarched

Are you touching and holding it? You have to have a continuous touch for like, 5 seconds, to engage/disenage control lock.

    Bookmark   August 17, 2008 at 11:56PM
Thank you for reporting this comment. Undo
solarpowered

From the manual, which is available online:

To unlock the cooktop:

Touch and hold the CONTROL LOCK pad
again for 5 seconds. A two-beep signal will
sound, and the CONTROL LOCK light will
go out, indicating that the cooktop is
unlocked.

    Bookmark   August 18, 2008 at 1:21AM
Thank you for reporting this comment. Undo
pbrahm1

Thanks for all your replies! Yes, I have the manual and have done what one is SUPPOSED to do when the you want to disengage the control lock. No response. The only response I get is when I cover the on/off buttons with my whole hand. After about 15 seconds I get 5 beeps and the 'e' for error light comes on. No problem with power.

The control lock light has been on since the unit was installed. It required a 220 connection, so my husband, with the guidance of his electrician friend, switched it from 110 to 220.

I'm guessing the sensor IS the issue. I have service scheduled to come out on Friday. Microwave cooking 'til then?

    Bookmark   August 18, 2008 at 2:53PM
Thank you for reporting this comment. Undo
klaa2

You are running 220 through a 110 line???? How many amps?

    Bookmark   August 18, 2008 at 3:53PM
Thank you for reporting this comment. Undo
pbrahm1

You're talking to the wrong person about electricity here, but NO! not running 220 through 110. REPLACED 110 with 220. My husband put in a new double switchy thingy : ) in the circuit breaker box. He knows what he's doing. I obviously don't. I believe it is the sensor. That makes the most sense.

    Bookmark   August 18, 2008 at 4:02PM
Thank you for reporting this comment. Undo
louisa_smith03

hi Patti-- just saw your mesage! the technician came out and evidently spent a few hours fiddling with it. Don't wha the did-- I was at work and GC's assistant was there-- but it works now. Evidently the technician was really annoyed by how difficult it was to fix.

    Bookmark   August 19, 2008 at 10:20AM
Thank you for reporting this comment. Undo
pbrahm1

Thanks everybody. Technician came out today and moved the sensor. Replaced the top and then it didn't work again. So he had to do it another time. I guess it's a little touchy! But wow!! It boils water fast!!!

    Bookmark   August 22, 2008 at 7:34PM
Thank you for reporting this comment. Undo
llaatt22

Enjoy!!

    Bookmark   August 22, 2008 at 7:57PM
Thank you for reporting this comment. Undo
karingwiz

I have a top of the line GE profile cooktop that is 1.5 years old that no longer works because its stuck in contriol lock which I never used before. I dont have an extended warranty. I woke up to find the control lock on and nothing I could do to get it out I am thinking the cat may have activated it. Service told me there would be a min $75 charge for the call and more charges every 15 mins. Likely some boards had to be replaced which would be expensive. But then I googled "cooktop stuck in control lock" and found this thread. I realized that the control lock "key" under the glass must not be positioned correctly so put my entire hand over the key (as mentioned by someone in this thread) and presto, out of control lock now! Wow, made my day! Internet can be wonderful!

    Bookmark   October 1, 2012 at 9:57AM
Thank you for reporting this comment. Undo
magnoliaeast

GE Profile 30" Induction Cooktop - 11" burner will not accept an appropriate sized pot/pan in the centered position.

I can eventually get it to connect but it can take more than 35-40 minutes to find the "sweet spot" which AGAIN is NOT the center of the 11 inch burner.

The other burners operate with no problem so I am reduced to having use of only 3 burners b/c of the time it takes to get the 11' burner to work.

Is there a sensor for the 11" burner that I can check?

    Bookmark   February 22, 2015 at 7:48PM
Thank you for reporting this comment. Undo
Susan Pluss

Thanks for all the answers... i pressed the red button (with warm hands) and held it for 15 sec and it worked !!!

    Bookmark   last Tuesday at 12:14PM
Sign Up to comment
More Discussions
Need A New Keurig - Suggestions?
Our Keurig at the lake bit the dust. The single cup...
amck2
Best duel fuel range
If you wanted duel fuel which would you go for?
nismo99
Fisher Paykel Dishwasher Drawers-do you have them?
I am in need of guidance. From what I can gather, it's...
beekeeperswife
High end appliances thermador vs. dacor
I currently have dacor ovens. I am trying decide brands...
mcaprizs
What electric oven to get? speed oven, combo-steam, or regular?
If I am going to go with an all gas range, which would...
nismo99
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™