MS Picture It Express 2000 4.0 HELP!

sapphiresJanuary 12, 2003

I have MS Picture It Express 2000 Version 4.0. I went to online site to get FREE templates, cards etc.. I clicked on download, saved in download folder, then found folder and clicked on .exe folder to install and got this msg:

To install this PictureItArt for use with MS Picture It, click yes. I did Then got this msg: This add on requires Picture It 3.0 or later, set up is cancelled. I have 2000 and version 4.0 Can someone tell me what I am doing wrong or what the fix or solution to this problem is? Thank you. W98SE IE 5.5 I don't have many art things to choose from and was looking for goodies. Help.

Sapphires

Thank you for reporting this comment. Undo
Peggy_GA

I have MS Picture It 2000, version 4.0. Not sure what you mean by "Express."

It's been a long time since I have gotten any new templates, but I'll check it out and see if I have any problems and let you know.

    Bookmark   January 14, 2003 at 6:09PM
Thank you for reporting this comment. Undo
sapphires

Peggy,
Any help appreciated. Thanks.'
Sapphires

    Bookmark   January 14, 2003 at 6:42PM
Thank you for reporting this comment. Undo
Peggy_GA

Hi Sapphires,

I just tried it and it worked. Are you sure you are downloading for 2000? I don't think downloads for 2001 or 02 would work.

Here is the link I used. You will see a list of downloads "For Picture It 2000" on the right side of the page.

Here is a link that might be useful: Picture It 2000 Downloads

    Bookmark   January 14, 2003 at 7:02PM
Thank you for reporting this comment. Undo
sapphires

Peggy,
Yeah that's the site I went to. I downloaded to desktop and when I clicked on the .exe file it said it installed successfully (some still gave error msg) but when I reopened PictureIt I don't see them there.
Sapphires

    Bookmark   January 14, 2003 at 9:24PM
Thank you for reporting this comment. Undo
Peggy_GA

What did you download...picture art or templates for projects?

    Bookmark   January 15, 2003 at 5:43PM
Thank you for reporting this comment. Undo
sapphires

Peggy,
Both I think whatever was available for the 2000.
Sapphires

    Bookmark   January 16, 2003 at 4:01PM
Thank you for reporting this comment. Undo
Peggy_GA

Gosh, Sapphires, I'm not sure what the problem could be. I just downloaded several and they all went through fine. Do you use IE5.0 or later?

You might want to check the support section to see if you can find out what the problem is. Here is the link.....

Here is a link that might be useful: PI 2000 Support

    Bookmark   January 17, 2003 at 1:52PM
Sign Up to comment
More Discussions
Funhouse Photo Software
I just got a free copy of ArcSoft's Funhouse software...
SueZQue
Please Help a GW friend in need?
Sorry for the oblique title, but not sure how to ask...
leahcate
fake money
Is there a web site where I can print off fake money...
arnl279
picture it 2002 substitute
I had to get a new computer with Windows7. I had XP...
june_nd
Recommendation for paper for Candy Wrappers??
OK I did it finally, made the wrappers I wanted too,...
hailie419
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™