Sparks from the heating coil element on the electric stovetop.

DukkarMarch 4, 2013


I replaced the burner infinite switch (from Sears) on my Kenmore electric stovetop two months ago since turning it on was not heating the coil (the red power light would not come on). But after that, everything was working fine. We have been cooking on that heating coil element since then, but yesterday while my wife was cooking using a non-stick pan, suddenly sparks started coming out of the heating coil element. My wife quickly turned off the burner switch and the sparks stopped.

When I inspected the hetaing coil element, I could see severe damage and there was melted metal on the floor where the sparks touched the floor. Even the bottom of the non-stick pan was damaged. I removed the heating coil element and haven't used it. Two things to note:

1. The burner socket for that particular heating coil element was replaced by the earlier seller. I know that because I can see the new socket connected to the old wires using connectors.
2. The other three heating coil elements work fine which is what we are using for our cooking.

Please tell me what's going on. Did I wire the infinte switch incorrectly, but then why am I seeing the problem after two months? Is the entire electric stovetop unsafe for use?


Thank you for reporting this comment. Undo

You should post on the electrical wiring forum - you'll get better responses there. Personally, I'd hire a repairman to look at this or more likely replace the range.

    Bookmark   March 4, 2013 at 1:56PM
Thank you for reporting this comment. Undo

A problem would have appeared much sooner than two months of use if there's a problem with the replaced control. The element likely just failed/shorted-out. Not unusual. Oven elements can fail in the same fashion, flaring up in a blaze of sparks to some degree or other ... but it's usually not noticed by the user (the oven just turns up not heating) because one doesn't normally stand and watch the oven during use as is the case with burner elements.

    Bookmark   March 4, 2013 at 2:04PM
Thank you for reporting this comment. Undo

Replaced the element and the socket at the same time and you should be good to go.

This post was edited by steve340 on Wed, Mar 6, 13 at 23:53

    Bookmark   March 6, 2013 at 11:51PM
Thank you for reporting this comment. Undo


Update! I tried replacing the burner socket and the heating element, but no luck! I went to HD and bought the following for my Sears/Kenmore electric stovetop:

- Burner socket []
- Heating Element []

I followed the directions in this youtube video: Range/Stove/Oven Repair- Replacing the Surface Burner Receptacle (Whirlpool Part # 12001676) - []. I wasn't able to get porcelain wire connectors so I am using the plastic ones that came with the burner socket.

When i turn on the burner switch, the red light comes on but the heating element just does not get hot. My other 8-inch element had stopped working years ago and i never bothered to fix it, so i tried to fix that as well by replacing the burner socket and used the old heating element. same results: the red light comes on, but the heating element doesn't heat at all! What am i doing wrong? The wires of the previous burner sockets that the previous owner had replaced were soldered as opposed to me using wire connectors for the socket that I am replacing. Other than that, I would expect this to be a simple job!!

Now I only have the two 6-inch ones working. Any help before my wife talks me into calling a technician? :-)


    Bookmark   March 11, 2013 at 3:37PM
Thank you for reporting this comment. Undo

Surprise your wife and buy her a new range before she talks you into calling a technician :-)

    Bookmark   March 11, 2013 at 4:00PM
Thank you for reporting this comment. Undo

Without proper diagnosis it's impossible to be absolutely sure... but based on your description, the switch blew when the element shorted.
This is not uncommon with the type of element failure you had.

    Bookmark   March 12, 2013 at 4:29PM
Thank you for reporting this comment. Undo

Measure the DC resistance of the heating coil while it is disconnected from the stove.

Infinite is a BAD COIL (open circuit), other readings are generally ok.

The actual resistance varies a great deal as the coil heats up, so it is really not more than a continuity check.

If an element failed it may have damaged the control if it was hooked up and turned on.

    Bookmark   March 12, 2013 at 6:59PM
Sign Up to comment
More Discussions
30 inch dishwasher from Dacor?
Hi! I am a constant-lurker who is in the planning stages...
Appliance Budget -$15k. How to spend?
We have $15k in our appliance allowance. We need a...
Any experience with a Miele or other plumbed-in coffee machine?
Heavily considering a plumbed in cva4066ss Miele coffee...
Capital Culinarian 36" 6 burner vs American Range 36" 6 burner
Live in Vancouver BC and am having trouble making the...
Help with induction please
I am planning to buy induction when we reno the kitchen....
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™