1993 chevy c1500 knock noise

trueblue93November 20, 2013

I have a 1993 chevy c/k 1500 5speed 5.7 tbi , replaced the oil pump to try and eliminate what i thought was a bad pump. I was experiencing what thought was dry lifters but changing the pump i now see wasent the problem .. Under accelerating i experience a knocking noise but clears up after a little while ..when at an idle i see the oil pressure dips low but bring the rpms up and it goes back to arounds 40 I also noticed that when i shut the truck off while its knocking its takes longer to start ... Truck starts idles and drives fine until i try and merge on the expressway .. I thought it was thin oil i ran a little heavier oil in it but as soon as the truck heats up and i gas it theres the knock .. I have to pulling my hair out reading up one different diagnosis between knock sensors and spark knock.. The truck has 300k plus but seems to be a rebuild at an unknown milage. I have to also mention that i had put headers on the truck and have a 3" catless exhaust on the truck other parts installed were new oil pan/gasket kit . Any imput would be greatly appeciated

Thank you for reporting this comment. Undo
jemdandy

Can you tell the difference between the sounds of ignition knock, bearing knock. or piston slap? This would be a clue of where to look.

By your description, this knock appears when extra torque is produced. (The knock sensor can not tell the difference between piston slap or ignition knock. It senses the high frequency shock waves in the head or metal on which it is mounted. In fact, one way to test the knock sensor is to tap the head near the sensor with a hammer to see if it retards the ignition.)

At 300,000 miles, you may have a worn out engine. It could be a rebuilt, but you don't know how many miles ago. A worn piston will slap under load and this decreases when the piston is hot. The piston temperature will vary while operating. It gets hotter with increased loading.

You could have carbon build-up in the combustion chambers that causes ignition knock under increased load.

A likely candidate is worn main bearings (crank shaft). A worn crank bearing on either end of the crank may cause the seals to leak.

The ignition should retard a bit with falling vaccum such as when under high acceleration down a freeway ramp. If it does not, knocking can occur. With old style engines, this was accomplished with diaphragm device on the distributor. On newer engines, the manifold pressure is measured with a sensor and its signal used by the electronic system to set ignition advance. A failure in this system can cause bad ignition timing.

Another possibility is oil starvation but since you changed the oil pump, I'd expect the usual causes for oil starvation would have been corrected by you at that time: Items such as clogging pickup screen on the oil pump or trash in the oil pan that may get sucked onto the screen. Besides, oil starvation will cause rapid wear of affected parts and early failure. Apparently, you have been able to operate this engine for some time with this condition.

Another possibility is ignition timing. I am not familar with your engine and where the ignition system gets its timing signal. If you engine is of the old type where the timing is manually set off marks on the vibration damper, be aware that these marks are on the vibration damper ring and if the elastomer between the ring and hub debonds, the damper can slip carrying the timing marks out of place. To check for this, remove no 1 spark plug and feel for the piston to arrive at top dead center. Do this carefully. you do not want to smash something betweent he piston top and the head. Park the piston at top dead center (TDC) and then look at the timing marks. These should show TDC. If these are not TDC, obviously the marks can not be used to time the ignition. I have seen ignition timing set ahead or behind as much as 15 deg when the damper ring slipped.

Also, check the paint color of the damper and the engine top. It may be either red or blue. The damper color should match the engine color. The accessories may be on the right side or left side of the engine depending on what vehicle model it is installed in. Red or blue paint was used to denote a right or left build. The timing mark bracket may be on either the right or left and the damper mark will be placed accordingly. In rare cases when refurbishing an old engine, a mismached damper can be installed. New marks should be put on a mismatched damper. I do not think this is your problem since the engine runs ok.

    Bookmark   November 26, 2013 at 4:02AM
Sign Up to comment
More Discussions
Failing transmission questions
I have a 2001 Honda Odyssey, 167,000 miles. I've always...
catherinet
Lexus vs Toyota Avalon
OK guys, here is another one for you. (I apologize...
Lynne_SJO
99' Blazer won't start when it's cold!
I would love to talk to John_G. I read some responses...
fastedy
Running rich?
01 Taurus, Vulcan motor.owned for 4 months. Ran ok...
stoveguyy
Nissan 350Z P1757
My car Nissan 350Z 2007 has an issue. Trouble codes...
254qi
© 2015 Houzz Inc. Houzz® The new way to design your home™