Dishwasher won't heat

appliancejonMarch 19, 2013

I have a Kitchen Aid KUDS30FXBL2 dishwasher, 14 months old. First problem was poor water aggitation. Replaced the whole pump assembly. Aggitation was then fine. Then had intermittent power failures. Traced power line in crawl space and found critter chew...replaced the power line with proper romex. Aggitation fine, but dishwasher wasn't heating well, not cleaning (was fine before the pump went). Tried Hi-Temp Scrub, Sani-Rinse, etc. Cycles go for the normal time, but insufficuent heat. Replaced the heater coil, thermistat and soil sensor thermistor. All new. Temp still won't go above 118-120F.

Thank you for reporting this comment. Undo
realism

Have you called a repairman?

    Bookmark   March 19, 2013 at 2:47PM
Thank you for reporting this comment. Undo
weedmeister

You should be filling it with 120F water.

    Bookmark   March 19, 2013 at 4:57PM
Thank you for reporting this comment. Undo
appliancejon

Thanks for the follow-up posts. I have read about the low and high range for intake water. We have tried, as recommended, running the hot kitchen tap 'till it's hot. With this recommendation, will check actual temp of hot tap water. And no, I haven't called a repairman. But I have consulted a friend who is an actual appliance repair guy, and the local authorized Whirlpool repair shop has been very helpful with suggestions. This is a small friendly town. Next step is to run the diagnostic tests (had procedure literature sent to me today), and we'll see. Any suggestions are appreciated, and I will post further on this in case it helps others.

    Bookmark   March 19, 2013 at 10:28PM
Thank you for reporting this comment. Undo
weedmeister

On my KA (circa '05), if you run the Hi-Temp Scrub and the temperature does not reach 140f by the end of the heating cycle, it will throw a code and quit. Blinking lights. And it will not start until the code is cleared, which requires some magic words and weird finger gestures. Don't ask me how I know this.

    Bookmark   March 20, 2013 at 3:35PM
Thank you for reporting this comment. Undo
pkguy

The codes/repair diagnostic chart are usually in a plastic pocket attached behind the kickplate if any wonders where they are.

    Bookmark   March 21, 2013 at 12:14AM
Thank you for reporting this comment. Undo
appliancejon

The attempt goes on. I found the diagnostic code/trouble shooting sheet in the pocket of the kickplate. Only it was in French. By the way, I'm located in the United States. To obtain the one in English for my model/serial number, I had Whirpool's Cust Service Center email it to me. Common to most, if not all customer service centers, at first they said that they did not have access to it since it was a repair technican item. A bit of further pushing on my part resulted in the email. Will post the diagnosis results. Really odd thing is that cycles run normal times AND no out of the ordinary blinking lights. Any suggestions?

    Bookmark   March 21, 2013 at 8:43AM
Thank you for reporting this comment. Undo
mike_kaiser_gw

I'd suggest you post a message on the forums of ApplianceBlog.com. I've used them a number of times in the past and the support has been fantastic. They'll help you diagnose the problem and point you to repair parts if needed.

Standard disclaimer - I have no affiliation or financial interest in the site.

Here is a link that might be useful: Appliance Blog

    Bookmark   March 21, 2013 at 9:14AM
Sign Up to comment
More Discussions
Seeking Bosch Benchmark Feedback
I know there have been a few posts regarding the new...
nadianyc
Questions about noisy back draft damper on vent hood roof cap
One female here who is definitely not a diy type person....
texasgal47
Wolf porcelain chipping on new ovens
Argggggg!!!! New wolf E series ovens, purchased and...
jackson2348
Island hood location/height
I've got a cooktop that's 20" X 37" that...
dickross
Anyone have experience with Ad Mark (eBay) appliance dealer?
Am considering buying Gagg induction cooktop + combi...
myniyer
© 2015 Houzz Inc. Houzz® The new way to design your home™