Hard to start when hot

westranchSeptember 8, 2009

My 1988 Mercury Grand Marquis (149k) is only hard to start when the engine is hot and has already been running. I have to give the car some gas, then quickly put it into drive to keep the engine from stalling in park. Any ideas? Someone suggested a vacuum leak?

Thank you for reporting this comment. Undo
gary__

EGR valve, idle air control, or maybe the mass air flow sensor comes to my mind. Hopefully someone with more recent experience than mine will chime in.

Bottom line is it could be a number of things. The only thing to do get someone with some diagnostic capabilties to have a look at it. There's a chance that that symptom indicates a particular thing a high percentage of the time on that particular car, but I wouldn't bet on it. Good luck.

    Bookmark   September 9, 2009 at 10:04PM
Sign Up to comment
More Discussions
99' Blazer won't start when it's cold!
I would love to talk to John_G. I read some responses...
fastedy
Blown tire on a dying car........
Well, in my other post I talked about how my transmission...
catherinet
Nissan 350Z P1757
My car Nissan 350Z 2007 has an issue. Trouble codes...
254qi
Honda Odyssey 2005 EX-L Fire
Hi All, My Honda Odyssey 2005 EX-L recently totaled...
mhs21
pump keeps stopping when trying to fill gas tank
Hi! Can someone give me a clue what might be suddenly...
twinklenose
Sponsored Products
Making Music Gramophone
$149.99 | Dot & Bo
Dale Tiffany Lamps 28 in. Boehme Antique Golden Sand Buffet Lamp TB101113
Home Depot
PH 4/3 Pendant by Louis Poulsen
$588.00 | Lumens
Small Flower Market Compote
$72.00 | Horchow
Hand-tufted Hesiod Light Blue Rug (8' x 8' Round)
Overstock.com
Kina Lillet Wall Art
Grandin Road
Toscana Italian Collection Footed Round Presentation Bowl
$149.50 | FRONTGATE
Hopson Leather Ottoman - Brighton Parrot Red
Joybird Furniture
© 2015 Houzz Inc. Houzz® The new way to design your home™