Speedometer Sensor

mister_alAugust 5, 2008

I have a 1992 Pontiac Grand Am (SE) with a V6 engine and Auto transmission. A couple of days ago the speedometer sensor started going out on me--speedometer doesn't work at times; Check Engine light comes on; car runs rough, and sometimes at high idle; stalls out; and the air conditioner doesn't cool. All this happens at about the same time, then suddenly everything starts working (for a while), and then it starts acting up again just as suddenly.

I don't mind replacing the sensor myself, but I can't find out where it's located. I can find all sorts of information on 'speedometer sensors' on the internet except where it is located on this particular make and model car. If anybody can help me out I'd be gratefull.

Alan

Thank you for reporting this comment. Undo
kalining

Phone your dealer and ask him.

    Bookmark   August 5, 2008 at 11:05AM
Thank you for reporting this comment. Undo
mister_al

I've called 3 different dealers this morning and was told by one that the sensors were located at each wheel, another place told me that the sensor was located on the transmission but he wasn't sure where, and the third place told me pretty much the same thing as the second place did.

I'm going to call them back after lunch and see if I have any better luck.

Alan

    Bookmark   August 5, 2008 at 1:18PM
Thank you for reporting this comment. Undo
kalining

The sensor is located on the right side axil on the transmission. the wheel sensors are for the a.b.s. That
car is famous for broken wires in that area. you might want to check that first before spending money on a sensor
you might not need.

    Bookmark   August 5, 2008 at 6:11PM
Thank you for reporting this comment. Undo
mister_al

Thanks for the tip kalining. I hadn't even considered the wiring as being the culprit. I will check it out first thing in the morning.

Alan

    Bookmark   August 5, 2008 at 10:29PM
Thank you for reporting this comment. Undo
mister_al

I just wanted to let everyone know that the problems I was having with my Grand Am turned out to be the Engine Control Computer. I replaced it and everything has gone back to working like it should.

Thanks for the help,
Alan

    Bookmark   August 9, 2008 at 3:43PM
Thank you for reporting this comment. Undo
kalining

Thanks for the feed back. We all get to learn something.

    Bookmark   August 10, 2008 at 9:33PM
Sign Up to comment
More Discussions
Honda Odyssey 2005 EX-L Fire
Hi All, My Honda Odyssey 2005 EX-L recently totaled...
mhs21
Radio antenna badly bent at car wash
I know this is going to sound really stupid but what...
africanboy
2004 Madza Tribute Catalytic converters
My daughters 2004 Tribute would not accelerate and...
good36
Cost to replace a 99 Buick head Gasket
My grandson 99 Buick blew a head gasket after the thermostat...
iggie
Dying transmission question
I have a 2001 Honda Odyssey that has served me well...
catherinet
Sponsored Products
Berg USA X-plorer XT Pedal Go Kart - 03.50.42.00
$899.00 | Hayneedle
Berg USA New Holland AF Pedal Go Kart Riding Toy - 03.73.82.00
$999.00 | Hayneedle
Berg USA Racing GT Pedal Go Kart - 03.55.82.00
$899.00 | Hayneedle
Berg USA Ferrari FXX Pedal Go Kart Riding Toy - 06.26.52.00
$899.00 | Hayneedle
Berg USA Case-IH AF Pedal Go Kart Riding Toy - 03.73.72.00
$999.00 | Hayneedle
Berg USA Case-IH BF Pedal Go Kart Riding Toy - 03.73.73.00
Hayneedle
Berg USA Safari AF Pedal Go Kart - 03.74.32.00
$899.00 | Hayneedle
Berg USA New Holland BF Pedal Go Kart Riding Toy - 03.73.83.00
Hayneedle
© 2015 Houzz Inc. Houzz® The new way to design your home™