1988 Olds Delta88

jasper60103March 8, 2008

I just picked up a 1988 Olds Delta88 w/64000 miles from my Mom.

Yesterday, I drove it from Chicago to Minneapolis,

439 miles door to door. The engine sounds great, but

I was getting an occasional "SES" light during the trip.

Also, I felt a thump a couple times when the light came on.

I just pulled the codes this morning using the paper clip method. (These old cars are kinda neat).

13 Oxygen sensor Circuit

Check for a sticking or misadjusted throttle position sensor. Check the wiring and connectors from the oxygen sensor. Replace the oxygen sensor.

41 EST circuit

No distributor reference pulses to the ECM at specified engine vacuum

Can you tell me if these two are related?

There was no recommended action for the code 41, not sure what to do?

Also, where is the oxygen sensor(s) and throttle position sensor? Is this easy to check?

thanks much.

jasper

Thank you for reporting this comment. Undo
kalining

The codes are not related. Do you have a 3.8 ?
Code 41 is very common when the magnet on the cam sensor
falls out. If you have a 3.8 there are usually 2 02 sensors
in the Y pipe at the head.One in the front. One in the back. Good Luck. Nice car.

    Bookmark   March 8, 2008 at 2:09PM
Thank you for reporting this comment. Undo
jasper60103

I have a V6 3800 3.8L.

I replaced the O2 sensor and the code 13 went away, yeh!

I still have a code 41 (EST - Electronic Spark Timing) though.
I let the car just sit and idle for 20 mins or so and this code appeared again.

Can you tell me if the code 41 is serious? The car seems to be running fine.
I have to research the internet on how to check the cam sensor. I don't have
a manual. Any help appreciated. thanks,

jasper

    Bookmark   March 9, 2008 at 9:15PM
Thank you for reporting this comment. Undo
jasper60103

Correction.

I have a V6 3800, not the 3.8.

    Bookmark   March 9, 2008 at 11:34PM
Thank you for reporting this comment. Undo
kalining

3800,3.8. It's the same thing. Yes this can get serious. This times the spark and injectors. Serious engine damage could happen. To check this you almost, actually you should
remove the sensor to see if the magnet is still there. I
dought it will be. If it is it will be damaged or unplugged. there is an easy way to test it but you need an
analog volt meter. Digital will not work properly.

    Bookmark   March 10, 2008 at 12:38PM
Thank you for reporting this comment. Undo
jasper60103

Kalining,
thanks for your help. Guess you can tell I'm a novice.

It seems it would be misfiring if the timing wasn't there, but its actually running very smooth.

Anyway, I'll check if the magnet is there.
I think I can locate the cam sensor. I read somewhere to remove the cam sensor and use a mirror to look thru the cam sensor hole to see if the magnet is there. But how do you manually turn the engine? And does it turn clockwise or counterclockwise?

thanks,

jasper

    Bookmark   March 10, 2008 at 2:20PM
Thank you for reporting this comment. Undo
kalining

It's made that way. Called limp mode. My car ran perfectly
for months with out the magnet and the " half moon " missing. Had an erratic idle from time to time but never quit. Put a socket on the balancer pulley bolt with a johnson bar or long handel ratchet and turn clockwize. You
will know if you turn it the wrong way. The bolt will come off. Make damn sure you remove the wrench from the bolt
before you accidentally turn the motor over with the starter. I've seen it done. Makes quite a mess. good luck

    Bookmark   March 10, 2008 at 4:31PM
Thank you for reporting this comment. Undo
jasper60103

Kalining:
yea, after researching it some more, I came across the limp mode explaination. That makes sense. I haven't driven the car since last Friday, and don't intend to until the problem is solved.

Anyway, I just took a look at the engine trying to find the Camshaft Position Sensor. No luck so far. I would like to verify the wiring and connection to that point.
If the wiring/connection checks out OK, I will have to take it to a mechanic. I think I'm getting in over my head.

If you can help me find the CPS, I'd appreciate it.
Thanks again for all your help.

jasper

    Bookmark   March 10, 2008 at 6:52PM
Thank you for reporting this comment. Undo
jasper60103

Ok, I searched and searched the web until I found a good pic that shows where the camshaft position sensor is located. Hope this helps someone. Now, off to the garage.

    Bookmark   March 10, 2008 at 8:53PM
Thank you for reporting this comment. Undo
kalining

It's in the chain cover. The crank shaft pulley and maybe the water pump will have to be removed first. This is after
you drain the antifreeze and some oil because the first
4 bolts of the oil pan have to be removed. They hold down the bottom of the chain cover. Make sure you check the
interupter too. You might want to think about sending it out. Your first time with all tools, new gaskets and seals might take 5 hours. Good experience if you have the time
and patients. The FIRST thing you do is buy the manual.

    Bookmark   March 10, 2008 at 9:25PM
Thank you for reporting this comment. Undo
jasper60103

Kalining:
Maybe I should give it a try. I have the time. I guess if the manual is detailed enough for the novice, I could probably do the job over a weekend. I hear the helm shop manual recommended a lot, but it costs $105. See description below. Is this what you recommend, or others? Any special tools needed? I already have the basics like sockets, wrenches, ramps, jack stands, etc. I've done some basic auto maintenance work in the past, but nothing like this.

thanks,

jasper

Description:
Instructions And Procedures For Routine Repair Adjustment Maintenance Work Diagnosis/Testing And Removal/Installation Of Parts For Various Vehicle Systems.

Here is a link that might be useful: helminc.com

    Bookmark   March 10, 2008 at 10:47PM
Thank you for reporting this comment. Undo
jasper60103

Actually, I found it on ebay for a fraction of the cost...

"1988 Oldsmobile Chassis Service Manual Delta 88 Royale Ninety-Eight Regency" Written for Oldsmobile dealership mechanics, this factory-published original manual shows you how to work on your vehicle. With step-by-step instructions, clear pictures, exploded view illustrations, wiring diagrams, schematics, and specifications, you will have the information you need to get your project on the road and keep it there. Find out what is covered by clicking here to see the table of contents. This book retails for $105.00. This manual covers all 1988 Oldsmobile Delta 88 Royale, 98 Regency models including Touring, & Brougham. This book measures 8.5 in. x 11 in. and is 2 in. thick. Very good condition. Buy now to own the best manual for your vehicle.

    Bookmark   March 10, 2008 at 11:22PM
Thank you for reporting this comment. Undo
kalining

Give it a shot. One thing i will tell you. Make absolutely
positive the sealing surfaces are clean and dry when you
replace the gaskets and seal. You do not want any leaks
after the fact. One hint. Loosen all bolts from the oil pan
and pull it down. This gets the extra clearence you need to replace the chain cover. If the pan is not pulled down a
little you will push out the bottom of the chain cover gasket as you replace it. You do get a modified gasket for
the chain cover in the gasket set. While your at it and if you want to keep the car check the chain and gear set.
Have fun. Good luck

    Bookmark   March 11, 2008 at 11:51AM
Thank you for reporting this comment. Undo
jasper60103

Hey Kalining.
I just wanted to follow up and let you know I fixed my code 41 problem.

I was able to verify the magnet was still there by peeking thru the cam sensor hole and manually turning the engine. So I decided to just replace the cam sensor. Well it turns out that did the trick!! Its been a couple days and no SES light!

I'm so happy about all the money I saved. I spent about $65 for the O2 and Cam senser and a few tools. And all the labor was free!!

I plan to do my brakes next. I ordered a repair manual off ebay and should receive it soon.
I learned a lot from this experience. Thanks again for your help.

jasper

    Bookmark   March 18, 2008 at 7:10AM
Thank you for reporting this comment. Undo
kalining

Good for you. Job well done. Good feeling to know that you
actually fixed it and it works isn't it. Take your time on your brakes and do one wheel at a time so you don't get
things mixed up. There is a left and a right. you will be
fine.

    Bookmark   March 18, 2008 at 11:11AM
Sign Up to comment
More Discussions
2004 Madza Tribute Catalytic converters
My daughters 2004 Tribute would not accelerate and...
good36
truck locked up tight
350 in 96 1500 locked up tight. Just driving down the...
timlynn
Honda Odyssey 2005 EX-L Fire
Hi All, My Honda Odyssey 2005 EX-L recently totaled...
mhs21
Cost to replace a 99 Buick head Gasket
My grandson 99 Buick blew a head gasket after the thermostat...
iggie
Consumer reports
I can't find a Consumer Reports Used car buying guide....
evaf555
Sponsored Products
Harris Reclaimed Wood Bed
Dot & Bo
CEP Floor Lamp
Lightology
Hinkley Olde Copper Essence 16 3/4" Low Voltage Path Light
$99.90 | Lamps Plus
Ashton 6-lt Chandelier
LBC Lighting
Holtkoetter | Bernie Turbo LED Low Voltage Table Lamp No. 6477LED
$678.00 | YLighting
Argento Bell Pendant by Corbett Lighting
$414.00 | Lumens
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™