speedometer+odometer nowork@X.'s

guitar42January 27, 2008

Every now and then the speedometer and odometer on my ford ranger dont register(when I'm driving down the road of course). When I start the truck like say, the next a.m., everythings fine. Any ideas?

Thank you for reporting this comment. Undo
ky114

I'm not sure if the speedometer in the Ranger is electrical or mechanical. What year is it?

    Bookmark   January 30, 2008 at 11:53AM
Thank you for reporting this comment. Undo
guitar42

Hi!
Yes, it's a '97 ford and speedo is electrical.

    Bookmark   January 30, 2008 at 4:17PM
Thank you for reporting this comment. Undo
jemdandy

There's a good chance that it is the "distance sensor". This sensor transmits pulses proportional to the speed of the output shaft of the transmission. It's located on the transmission in the same location where the older style speedometer cable once was.

    Bookmark   February 24, 2008 at 3:03AM
Sign Up to comment
More Discussions
1992 Chevy Truck 1500 running BAD!
About 2 1/2 years ago my truck was running bad, had...
arkansas_girl
Lexus vs Toyota Avalon
OK guys, here is another one for you. (I apologize...
Lynne_SJO
car alarm going off at odd times
We have a Hyundai that suddenly decided the entire...
Chickey Wingz
Problem with remote starter
I had a remote starter (AS-1780) installed on my 2014...
coryL
1998 Dodge Caravan - Electrical Problems !?
Hi Folks, seems rather quite here, but I've got nothing...
vgkg
© 2015 Houzz Inc. Houzz® The new way to design your home™