GE Profile MW Trim Kit install question

MuffettJanuary 27, 2014

My contractor installed my Profile Microwave and Trim Kit in a new cabinet. It appears level and centered. However, when I open the microwave door it rubs on the left hand side of the frame and really doesn't open fully. I even pulled back the protective coating assuming that may contribute to the rub - no change in operation. Based on the instructions, this didn't seem like a difficult install.

Does anyone have any tips / tricks or things to try? Or is this expected behavior with a trim kit (if it is, I'm sad!)

Thank you for reporting this comment. Undo
weissman

No, this isn't expected behavior - are you sure it's the correct trim kit for your particular MW? If so, you could call GE and see what they say.

    Bookmark   January 27, 2014 at 10:19AM
Thank you for reporting this comment. Undo
Muffett

I called GE and a replacement trim kit has been sent in case there was a defect. Wish me luck for installation round 2!

    Bookmark   January 28, 2014 at 9:48AM
Thank you for reporting this comment. Undo
Muffett

New trim kit installed and door opens like a charm. Now I can't wait to use it!

    Bookmark   January 29, 2014 at 6:49AM
Sign Up to comment
More Discussions
Anyone with a double oven range wish they had gone with wall ovens?
My DH thought we'd get a double oven range, but I like...
happyallison
Shark Hard Surface Steam CleanerSE3306C steam not coming out of nozzle
Hi, Our Shark Hard Surface Steam Cleaner is heating...
danadevy
Does Anyone have the Wolf Range with a Griddle?
I've got one and I find the grease doesn't drip into...
sbedelman
Fisher Paykel RF201ADX4 - Anyone have this fridge??
Hi Everyone, This fridge has a pretty good price right...
LiliReno
Replacing slide in range with range top
Would like to remove current stove/oven and install...
itsmekelli
People viewed this after searching for:
© 2015 Houzz Inc. Houzz® The new way to design your home™